March 26, 2014

DOCOMO to Offer LTE Roaming for Customers Traveling outside Japan

  • Print

Products & Services

TOKYO, JAPAN, March 26, 2014 --- NTT DOCOMO, INC., a personalized mobile solutions provider for smarter living, announced today that it will launch an outbound LTE roaming service for subscribers traveling in eight countries and regions, including popular travel destinations such as the mainland USA and Hawaii, Hong Kong and France, beginning March 31.

Existing flat-rate data roaming plans will be applied to the service, allowing DOCOMO users to enjoy roaming with confidence on ultra-high-speed LTE mobile networks overseas.

Going forward, DOCOMO will continue to expand its global LTE roaming coverage, teaming up with additional overseas partners to further enhance mobile experiences for the increased convenience and satisfaction of DOCOMO's Japan-leading customer base.

(Open a PDF file)(Attachment) Availability of DOCOMO's LTE roaming service (PDF format: 12KB)

About NTT DOCOMO

NTT DOCOMO provides innovative, convenient and secure mobile services that enable smarter living for each customer. The company serves over 62 million mobile customers in Japan via advanced wireless networks, including a nationwide 3G network and one of the world's first commercial LTE networks. Leveraging its unique capabilities as a mobile operator, DOCOMO is a leading developer of cutting-edge technologies for NFC mobile payments, mobile GPS, mobile TV, intuitive mobile assistance, environmental monitoring, smart grids and much more. Overseas, the company provides technical and operational expertise to eight mobile operators and other partner companies. NTT DOCOMO is listed on the Tokyo (9437) and New York (DCM) stock exchanges. Please visit https://www.nttdocomo.co.jp/english/ for more information.

Adobe Reader(Page will open in a new window)

In order to view PDF files, you must have the Page will open in a new window.Adobe® Reader® plug-in offered free of charge from Adobe Systems, Inc. When viewing the PDF files with Adobe® Acrobat®, use version 10 or later.

Go to top of the page